Much Better Synchronization Speed

I have just tried the latest Musicoin Wallet v1.0, the synchronization speed is insanely fast. Wow.
What is the magic in it? It used to take a couple of hours but now it finished synchronization within 10 minutes.

alt text

“Improved fast sync in compliance with go-ethereum has reduced the chain size to < 10 GB” - if you read what’s new

New wallet looks great! Big up for playing music in the music wallet…
Took a long time till i got connections to peers about ?15min. It was dropping them it seems, showing 0 most of the time 0 1 0 1 0 2 0 1 0 2 0 3 0 1 0 and so on

administrators

@mjmoonbow-aka-tinman said in Much Better Synchronization Speed:

Took a long time till i got connections to peers about ?15min. It was dropping them it seems, showing 0 most of the time 0 1 0 1 0 2 0 1 0 2 0 3 0 1 0 and so on

This means gmc trying connection to peer, but peer seems non stable enough, not in the access from your location, or just off. At some point it should find new peers good for your location and save the new list peers locally. Most peers a just users with wallet just like you. However you can switch back to small list of peers with Advanced - Restore default nodes list. But in case is going ok now, you better not to do it, since the smaller the list, the harder is to bootstrap. But if you haven’t problem with synchronization before, small list could be actually faster for you, since you discovering peers good enough by yourself.

Yes and about blockchain size with fast option is less than 5GB from the start now, but in case you will restart the wallet fast mode will be disabled automatically. And if you had some blockchain data downloaded from the previous version, it can’t continue in the fast mode ether.

last edited by cryptofuture

The reduced blockchaindata is really a huge advantage! Guess i retry to run a node on my old laptop 🙂

Can we change the datachain folder?

administrators

@thibault-shagersword said in Much Better Synchronization Speed:

Can we change the datachain folder?

It always located at \AppData\Roaming\Musicoin\gmc folder under Windows, in ~./musicoin/gmc under Linux and in Username/Library/Musicoin/gmc under macOS.

Before it was hardcoded, so if your main disk in windows was G for example (this happens quite rare through) or you home directory in Linux was somewhere outside /home - like some live-cd do, wallet did not worked.

But, yes you quite limited for moving it on another disk, however you can always do symlink to gmc folder from another location. Windows has same ability starting some NTFS version, it cooled shadow copies, or something. Anyway should possible to find in the google, if you really want to move it.

Beside you can run gmc in standalone mode, without binary that comes with wallet, with --datadir.

Or actually you can edit config.std.js (you better to redownload nightly build, since config directory from the home or appdata was not actually used, and that was fixed like 20 minutes ago) file manually and add datadir option. Adding as feature in like Advanced menu, can make wallet not functional, in case person will type incorrect path for datadir actually could a folder choose dialog, so I’ll look into it, same apply to wipe blockchain option, since those could be dangerous for most users too. But if more people would ask for it, it could be done.

last edited by cryptofuture

Full sync in just 45 min… 5gb folder size… woooot
I just had the idea to promote the artist of the week on the lower wallet window… would be awesome with a play button 🙂

administrators

Seems like a good idea! We’ll think about implementing it in the next release.

@frank-chang did you add any peer cos mine seems to stuck. i downloaded it yesterday then open it and it just sit there, no sign of connection. please can you help?

@ladonsyl-dozie-nwodo try to add peers… open the wallet and there is an add peer option in advanced menu

@mjmoonbow-aka-tinman Thanks for the reply. I have found some peer at github page but it seem to show no signs of connecting. If i try to play music using the “Play Music” button in the wallet, it plays which show its connected to the internet. I really do not know what’s up with it.

try to deinstall and delete the Musicoinfolder in AppData/Roaming no idea where that on a mac is…

administrators

I finished separate app to bulk filter nodes. So pretty soon we would test improved synchronization.

last edited by cryptofuture

Looks like your connection to Musicoin Forum was lost, please wait while we try to reconnect.